What are the minimum device requirements for BTD 6?

Sam -

Apple devices: The game requires iOS 11.0 or later. Compatible with iPhone, iPad, and iPod touch. It's also best experienced on iPhone 7 or above, or on iPad mini 4 or above.

Android devices: The minimum requirement for Android devices varies depending on the device you're using.

Have more questions? Submit a request